re = /https?:\/\/(?![^" <>]*(?:jpg|png|gif))[^" <>]+/
str = 'http://www.ex1.ir/new-img/im.png
http://www.ex2.ir/d1/d2
http://www.ex3.ir/1.gif
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end