const regex = new RegExp('https?://(?![^" <>]*(?:jpg|png|gif))[^" <>]+', '')
const str = `http://www.ex1.ir/new-img/im.png
http://www.ex2.ir/d1/d2
http://www.ex3.ir/1.gif
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}