import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://(?![^\" <>]*(?:jpg|png|gif))[^\" <>]+";
final String string = "http://www.ex1.ir/new-img/im.png\n"
+ "http://www.ex2.ir/d1/d2 \n"
+ "http://www.ex3.ir/1.gif \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}