using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://(?![^"" <>]*(?:jpg|png|gif))[^"" <>]+";
string input = @"http://www.ex1.ir/new-img/im.png
http://www.ex2.ir/d1/d2
http://www.ex3.ir/1.gif
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}