use strict;
my $str = 'http://www.ex1.ir/new-img/im.png
http://www.ex2.ir/d1/d2
http://www.ex3.ir/1.gif
';
my $regex = qr~https?://(?![^" <>]*(?:jpg|png|gif))[^" <>]+~p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}