import Foundation
let pattern = #"def\s+(\w+)\((\w+),\s*(\w+)\):"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"def wrloc(imm_value, imm_address):"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".macro \1_imm \2 \3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}