# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/def\s+(\w+)\((\w+),\s*(\w+)\):/.macro \1_imm \2 \3/;t' <<< "def wrloc(imm_value, imm_address):"