$re = '/def\s+(\w+)\((\w+),\s*(\w+)\):/';
$str = 'def wrloc(imm_value, imm_address):';
$subst = ".macro \1_imm \2 \3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;