const regex = /def\s+(\w+)\((\w+),\s*(\w+)\):/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('def\\s+(\\w+)\\((\\w+),\\s*(\\w+)\\):', '')
const str = `def wrloc(imm_value, imm_address):`;
const subst = `.macro \1_imm \2 \3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);