#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "def\s+(\w+)\((\w+),\s*(\w+)\):"
Local $sString = "def wrloc(imm_value, imm_address):"
Local $sSubst = ".macro \1_imm \2 \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)