use strict;
my $str = 'def wrloc(imm_value, imm_address):';
my $regex = qr/def\s+(\w+)\((\w+),\s*(\w+)\):/p;
my $subst = '.macro \\1_imm \\2 \\3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";