$re = '/(")([^"]*)(")|(\')([^\']*)(\')/';
$str = '"com s\'ha fet?" \'El "milor" que es pot!\'';
$subst = "\2\n\5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;