use strict;
my $str = '"com s\'ha fet?" \'El "milor" que es pot!\'';
my $regex = qr/(")([^"]*)(")|(')([^']*)(')/p;
my $subst = '\\2\\n\\5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";