# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(")([^"]*)(")|(')([^']*)(')/\2\n\5/g;t' <<< "\"com s'ha fet?\" 'El \"milor\" que es pot!'"