using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("")([^""]*)("")|(')([^']*)(')";
string substitution = @"\2\n\5";
string input = @"""com s'ha fet?"" 'El ""milor"" que es pot!'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}