const regex = /(")([^"]*)(")|(')([^']*)(')/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(")([^"]*)(")|(\')([^\']*)(\')', 'g')
const str = `"com s'ha fet?" 'El "milor" que es pot!'`;
const subst = `\2\n\5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);