// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(= new ReportViewModel\d+)\((id)\)").unwrap();
let string = "= new ReportViewModel83(id)
= new ReportViewModel8(id)
= new ReportViewModel111(id)
= new ReportViewModel20()
= new ReportViewModel1(null)";
let substitution = "$1($2,_ModelParam.Id)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}