re = /(= new ReportViewModel\d+)\((id)\)/m
str = '= new ReportViewModel83(id)
= new ReportViewModel8(id)
= new ReportViewModel111(id)
= new ReportViewModel20()
= new ReportViewModel1(null)'
subst = '$1($2,_ModelParam.Id)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result