const regex = /(= new ReportViewModel\d+)\((id)\)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(= new ReportViewModel\\d+)\\((id)\\)', 'mg')
const str = `= new ReportViewModel83(id)
= new ReportViewModel8(id)
= new ReportViewModel111(id)
= new ReportViewModel20()
= new ReportViewModel1(null)`;
const subst = `$1($2,_ModelParam.Id)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);