package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(= new ReportViewModel\d+)\((id)\)`)
var str = `= new ReportViewModel83(id)
= new ReportViewModel8(id)
= new ReportViewModel111(id)
= new ReportViewModel20()
= new ReportViewModel1(null)`
var substitution = "$1($2,_ModelParam.Id)"
fmt.Println(re.ReplaceAllString(str, substitution))
}