# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(= new ReportViewModel\d+)\((id)\)/$1($2,_ModelParam.Id)/mg;t' <<< "= new ReportViewModel83(id)
= new ReportViewModel8(id)
= new ReportViewModel111(id)
= new ReportViewModel20()
= new ReportViewModel1(null)"