# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(= new ReportViewModel\d+)\((id)\)"
test_str = ("= new ReportViewModel83(id)\n"
"= new ReportViewModel8(id)\n"
"= new ReportViewModel111(id)\n"
"= new ReportViewModel20()\n"
"= new ReportViewModel1(null)")
subst = "$1($2,_ModelParam.Id)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.