re = /(http(s)?:[\/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+/
str = 'http://aaa.com.tw
https://aa-a.com.tw
http://aaa.com
https://aaa.com
aaa.com
aaa.com.tw'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result