import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http(s)?:[/]{2})?([a-z0-9][a-z0-9\\-]+.)+([a-z0-9\\-])+";
final String string = "http://aaa.com.tw\n"
+ "https://aa-a.com.tw\n"
+ "http://aaa.com\n"
+ "https://aaa.com\n"
+ "aaa.com\n"
+ "aaa.com.tw";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}