$re = '/(http(s)?:[/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+/';
$str = 'http://aaa.com.tw
https://aa-a.com.tw
http://aaa.com
https://aaa.com
aaa.com
aaa.com.tw';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;