const regex = /(http(s)?:[/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http(s)?:[\/]{2})?([a-z0-9][a-z0-9\\-]+.)+([a-z0-9\\-])+', 'g')
const str = `http://aaa.com.tw
https://aa-a.com.tw
http://aaa.com
https://aaa.com
aaa.com
aaa.com.tw`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);