#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(http(s)?:[/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+"
Local $sString = "http://aaa.com.tw" & @CRLF & _
"https://aa-a.com.tw" & @CRLF & _
"http://aaa.com" & @CRLF & _
"https://aaa.com" & @CRLF & _
"aaa.com" & @CRLF & _
"aaa.com.tw"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)