using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http(s)?:[/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+";
string substitution = @"";
string input = @"http://aaa.com.tw
https://aa-a.com.tw
http://aaa.com
https://aaa.com
aaa.com
aaa.com.tw";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}