import Foundation
let pattern = ##"\[\ \s*[a-z#A-Z_]+\s*-?\d+([\.]\d+)*\s*\ ]"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}