const regex = /\[\ \s*[a-z#A-Z_]+\s*-?\d+([\.]\d+)*\s*\ ]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\ \\s*[a-z#A-Z_]+\\s*-?\\d+([\\.]\\d+)*\\s*\\ ]', '')
const str = `test
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);