re = /\[\ \s*[a-z#A-Z_]+\s*-?\d+([\.]\d+)*\s*\ ]/
str = 'test
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result