$re = '/\[\ \s*[a-z#A-Z_]+\s*-?\d+([\.]\d+)*\s*\ ]/';
$str = 'test
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;