use strict;
my $str = 'test
';
my $regex = qr/\[\ \s*[a-z#A-Z_]+\s*-?\d+([\.]\d+)*\s*\ ]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";