// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\ \s*[a-z#A-Z_]+\s*-?\d+([\.]\d+)*\s*\ ]").unwrap();
let string = "test
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}