// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)([\.]{0,1}[a-zA-Z]{1,}[0-9]{0,}?\.)|([a-zA-Z]+?\([\S\s]+?\))").unwrap();
let string = "lista.tekste2.push('asdsad', 'asd')
.outrcoisa.lista.push(descricao,argumento2)
.outrcoisa.lista.push(descricao,argumento3)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}