import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\.]{0,1}[a-zA-Z]{1,}[0-9]{0,}?\\.)|([a-zA-Z]+?\\([\\S\\s]+?\\))";
final String string = "lista.tekste2.push('asdsad', 'asd')\n\n"
+ ".outrcoisa.lista.push(descricao,argumento2)\n\n"
+ ".outrcoisa.lista.push(descricao,argumento3)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}