#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)([\.]{0,1}[a-zA-Z]{1,}[0-9]{0,}?\.)|([a-zA-Z]+?\([\S\s]+?\))"
Local $sString = "lista.tekste2.push('asdsad', 'asd')" & @CRLF & _
"" & @CRLF & _
".outrcoisa.lista.push(descricao,argumento2)" & @CRLF & _
"" & @CRLF & _
".outrcoisa.lista.push(descricao,argumento3)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")