const regex = /([\.]{0,1}[a-zA-Z]{1,}[0-9]{0,}?\.)|([a-zA-Z]+?\([\S\s]+?\))/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\.]{0,1}[a-zA-Z]{1,}[0-9]{0,}?\\.)|([a-zA-Z]+?\\([\\S\\s]+?\\))', 'gu')
const str = `lista.tekste2.push('asdsad', 'asd')
.outrcoisa.lista.push(descricao,argumento2)
.outrcoisa.lista.push(descricao,argumento3)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}