$re = '/([\.]{0,1}[a-zA-Z]{1,}[0-9]{0,}?\.)|([a-zA-Z]+?\([\S\s]+?\))/u';
$str = 'lista.tekste2.push(\'asdsad\', \'asd\')
.outrcoisa.lista.push(descricao,argumento2)
.outrcoisa.lista.push(descricao,argumento3)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);