re = /([\.]{0,1}[a-zA-Z]{1,}[0-9]{0,}?\.)|([a-zA-Z]+?\([\S\s]+?\))/
str = 'lista.tekste2.push(\'asdsad\', \'asd\')
.outrcoisa.lista.push(descricao,argumento2)
.outrcoisa.lista.push(descricao,argumento3)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end