$re = '/
^((http|https):\/\/)?(www[0-9]\.)?(([A-Za-z0-9_-])+\.{1})+([A-Za-z]{2,4}|\<[^<>]+\>)(\/([A-Za-z0-9_-])+)*(\/)?$/m';
$str = 'https://www.google.com
http://www.google.net/hello
https://www.google.<var>
http://www.google.<hello>/hello
http://www.google.>hello</hello
http://www.google.<<hello>/hello
http://www.google.<<hello>>/hello
http://www.google.<hello>>/hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);