#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)" & @CRLF & _
"^((http|https):\/\/)?(www[0-9]\.)?(([A-Za-z0-9_-])+\.{1})+([A-Za-z]{2,4}|\<[^<>]+\>)(\/([A-Za-z0-9_-])+)*(\/)?$"
Local $sString = "https://www.google.com" & @CRLF & _
"http://www.google.net/hello" & @CRLF & _
"https://www.google.<var>" & @CRLF & _
"http://www.google.<hello>/hello" & @CRLF & _
"http://www.google.>hello</hello" & @CRLF & _
"http://www.google.<<hello>/hello" & @CRLF & _
"http://www.google.<<hello>>/hello" & @CRLF & _
"http://www.google.<hello>>/hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")