using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"
^((http|https):\/\/)?(www[0-9]\.)?(([A-Za-z0-9_-])+\.{1})+([A-Za-z]{2,4}|\<[^<>]+\>)(\/([A-Za-z0-9_-])+)*(\/)?$";
string input = @"https://www.google.com
http://www.google.net/hello
https://www.google.<var>
http://www.google.<hello>/hello
http://www.google.>hello</hello
http://www.google.<<hello>/hello
http://www.google.<<hello>>/hello
http://www.google.<hello>>/hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}