import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\n"
+ "^((http|https):\\/\\/)?(www[0-9]\\.)?(([A-Za-z0-9_-])+\\.{1})+([A-Za-z]{2,4}|\\<[^<>]+\\>)(\\/([A-Za-z0-9_-])+)*(\\/)?$";
final String string = "https://www.google.com\n"
+ "http://www.google.net/hello\n"
+ "https://www.google.<var>\n"
+ "http://www.google.<hello>/hello\n"
+ "http://www.google.>hello</hello\n"
+ "http://www.google.<<hello>/hello\n"
+ "http://www.google.<<hello>>/hello\n"
+ "http://www.google.<hello>>/hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}