package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)
^((http|https):\/\/)?(www[0-9]\.)?(([A-Za-z0-9_-])+\.{1})+([A-Za-z]{2,4}|\<[^<>]+\>)(\/([A-Za-z0-9_-])+)*(\/)?$`)
var str = `https://www.google.com
http://www.google.net/hello
https://www.google.<var>
http://www.google.<hello>/hello
http://www.google.>hello</hello
http://www.google.<<hello>/hello
http://www.google.<<hello>>/hello
http://www.google.<hello>>/hello`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}