use strict;
my $str = 'https://www.google.com
http://www.google.net/hello
https://www.google.<var>
http://www.google.<hello>/hello
http://www.google.>hello</hello
http://www.google.<<hello>/hello
http://www.google.<<hello>>/hello
http://www.google.<hello>>/hello';
my $regex = qr/
^((http|https):\/\/)?(www[0-9]\.)?(([A-Za-z0-9_-])+\.{1})+([A-Za-z]{2,4}|\<[^<>]+\>)(\/([A-Za-z0-9_-])+)*(\/)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}