re = /.*donotbackup.*/
str = 'donotbackup
test_donotbackup
donotbackup_test
test_donotbackup_test
TEST_DONOTBACKUP_TEST
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end