#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*donotbackup.*"
Local $sString = "donotbackup" & @CRLF & _
"test_donotbackup" & @CRLF & _
"donotbackup_test" & @CRLF & _
"test_donotbackup_test" & @CRLF & _
"TEST_DONOTBACKUP_TEST" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")