import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*donotbackup.*";
final String string = "donotbackup\n"
+ "test_donotbackup\n"
+ "donotbackup_test\n"
+ "test_donotbackup_test\n"
+ "TEST_DONOTBACKUP_TEST\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}