$re = '/.*donotbackup.*/';
$str = 'donotbackup
test_donotbackup
donotbackup_test
test_donotbackup_test
TEST_DONOTBACKUP_TEST
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);